Linuxで使えるプリンタ/スキャナ

1名無しさん@お腹いっぱい。2005/12/03(土) 03:34:54ID:sQMuVnEP
LinuxなどUNIX系OSで使えるプリンタ/スキャナについての情報交換スレです。

各社プリンタドライバ
http://cweb.canon.jp/drv-upd/bj/other.html
http://www.avasys.jp/linux/index.html (エプソン)
http://hpinkjet.sourceforge.net/
http://solutions.brother.co.jp/linux/

76名無しさん@お腹いっぱい。2007/10/22(月) 17:07:25ID:hWPbzSak
今,HP PSC2310をDebianで使っているのですが,
最近ADFが欲しくなってきました。

そこでHP Officejet 7210のADFがLinuxでちゃんと機能するのなら
買い換えようかと考えています。

HP Officejet 7210のADFはLinuxで動作しますか?
また,こしのある書籍の紙でも問題無くADFは動作するか
ご存知の方がいらしたら教えてください。

77762007/10/26(金) 23:32:26ID:Kxxh1XMJ
>>76
自己レスです。
7210のADFは自動両面はうまく動かないみたいですが,
片面では問題なく動くみたいです。

これなら特に問題にはならないので,購入する準備に入ることにします。

78名無しさん@お腹いっぱい。2008/02/06(水) 04:38:17ID:ckydPI7p
調べてみたんだが直接接続するネットワークスキャナが使えるのはEPSON、CANON、HPだと無いでFAでいいのかな?
Brotherだとあるみたいだね

79名無しさん@お腹いっぱい。2008/02/09(土) 04:04:13ID:VgCTPAXg
保守

80802008/03/29(土) 19:31:12ID:7abHYgks
xsaneで100.300.1200.2400以外の取り込み解像度の設定は出来ないのですか?
EPSON PM-A850なんですけど どなたかご存知ありませんか



  

81名無しさん@お腹いっぱい。2008/06/22(日) 09:50:37ID:tdmG2FXF
Brother MFC-870CDWN買った。
CentOS4で動作確認。
もともとWinで使うのに買ったんだけど、HP見たらLinuxドライバあってびっくりした。
知らなかったけど、LinuxerにはBrotherまずまず良いね。

82名無しさん@お腹いっぱい。2008/06/23(月) 17:32:50ID:5d73dsdS
せんと君は蟹Nicに厳しい orz

83名無しさん@お腹いっぱい。2008/06/23(月) 22:29:55ID:0lE4BY3r
>>82
Gentooへようこそ。
あなたは選択の自由とパフォーマンスの追求を許された世界に足を踏み入れようとしています。
Gentooとは選択です。

84名無しさん@お腹いっぱい。2008/06/24(火) 19:16:50ID:SgfkStMq
せんと君5.2からはギガ蟹がサポートされたお。

85名無しさん@お腹いっぱい。2008/06/30(月) 13:08:56ID:SkyLqnKa
FreeBSD(7.0p2, amd64)において、silexのUSBデバイスサーバ越しに
LAN非対応HPプリンタをネットワーク接続してCUPSから使えた。
ポートは9100や9101などのRAWを指定する。
K5400dn, 8230, D7360で動作確認。B9180は検出されるものの
このモデルのみドライバがないので動かすことはできない。

hp-setupはどのみちFreeBSDではまともに動かないし
(最終段階で「queueを作れない」というエラーメッセージが出る)、
デバイスサーバを介していると検出されない。

CANON LBPをLIPS-IVドライバ1.70で使ってみたが、FreeBSDでは
何とかコンパイルできるものの、GhostScriptとの通信に失敗してしまうようだ。

86名無しさん@お腹いっぱい。2008/08/23(土) 07:22:58ID:bQu1zQ51
>>78,81
ブラザーって、意外とLinuxへの対応がいいんだね。

87名無しさん@お腹いっぱい。2008/08/23(土) 08:51:37ID:IrffvG+S
LIPSやESC/PageもLinux対応はしてるが、純正PSあるいはPS互換だったら
CUPSでの設定が楽だし、メーカーもドライバ不要でコスト削減できる。

88名無しさん@お腹いっぱい。2008/09/17(水) 22:54:20ID:Jpu6mFFj
玲奈糞には劣糞魔悪がよく似合う。

89名無しさん@お腹いっぱい。2008/09/17(水) 23:01:56ID:NXnv/D07
HPが一番似合うでしょ。

DeskJet 5850はVistaではもはや使えないが、
hplipなら使えるしね〜

90名無しさん@お腹いっぱい。2008/10/04(土) 09:00:27ID:2LQL9A/W
PFUの fi-6130だけど、FreeBSD 7.0-STABLEで使えたよ
sane.d/fujitsu.confに 「usb 0x04c5 0x114f」
追加したから動いたのか、 src/sys/dev/usbの、usbdevsと、uscanner.cに追加したから動いたのかは謎

でも、xsane で長票取り込みできないのは鬱。
どうやるんだ?

91名無しさん@お腹いっぱい。2008/12/15(月) 18:19:28ID:xympSMyf
ソースがあるプリンタドライバがあれば、インクの消費を抑えるドライバなんかも書けそうだな。
まあ、そんなドライバはないのだがw

92名無しさん@お腹いっぱい。2008/12/15(月) 18:30:34ID:o8fvDFK6
>>91
つ「hplip」

93名無しさん@お腹いっぱい。2009/07/16(木) 18:40:04ID:u4smbqjN
>>20
亀レスですが
以前
http://unkar.jp/read/pc11.2ch.net/linux/1197184271
↑でGT-9700F(Perfection 2450)が動かないと言っていた者です。

https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/55272
ここを見て #rmmod echi-hcd
してから接続したら、動きました。フィルムスキャナも動作するようです。
もしGT9700Fが動かない人が居たら試してみることをお勧めします。

94名無しさん@お腹いっぱい。2010/03/15(月) 06:07:06ID:qnJ933Aq
hosyu

95名無しさん@お腹いっぱい。2010/04/03(土) 14:12:24ID:BbRF6v1K
全然別人だけど横レス。
まさに今日CanonのPIXUS MP640を買ったんだけど、
>>69をみたら普通に公式ドライバが配布されているみたいで
感動です。

96952010/04/03(土) 14:13:30ID:BbRF6v1K
で、私以外にCanonのPIXUS MP640をLinuxで使っている方がいたら
是非使い勝手・使い心地などを 教えてください。

97名無しさん@お腹いっぱい。2011/08/01(月) 21:22:32.84ID:4qjsyiCs
canonで使える一覧おしえてっぽ

98名無しさん@お腹いっぱい。2011/08/04(木) 17:39:47.61ID:7/WS8/WI
Canon LBP-1110用のGutenprintのドライバ?書いてくれよ

99名無しさん@お腹いっぱい。2011/11/25(金) 21:44:23.07ID:Pv8L67c4
test

100名無しさん@お腹いっぱい。2011/11/25(金) 22:35:56.78ID:b70wffNv
Linuxでプリンタ使いたければ、ほぼEPSONの一択

101名無しさん@お腹いっぱい。2011/11/26(土) 12:32:10.91ID:GEdSWX8B
hpを忘れられては困る。
hplip関連が入っていないトリは最近はもうないだろう。
つなぐだけで認識するし、複合機ならネット経由でスキャンも出来る。
一番困るのがキヤノンだな。
ブラザーは意外と対応しているという話だけど。

102名無しさん@お腹いっぱい。2011/12/09(金) 21:09:35.65ID:i3SFhOPh
>>93
亀レスですが
これでは動きませんでした
鳥が違うせいでしょうか
BIOSでUSB2を切ったら使えるようになりました

103名無しさん@お腹いっぱい。2011/12/10(土) 00:32:57.41ID:/Gfbl1Cb
lexmark・・・・

104名無しさん@お腹いっぱい。2011/12/28(水) 22:42:25.42ID:4CNl1yMw
Linuxで使えるプリンタを探しているのだが
どれを買ったら大丈夫なのかよく分からない・・・
なにか、おすすめとかあれば聞きたい
主な用途はoofficeで印刷することで、写真とかの印刷はしない。

105名無しさん@お腹いっぱい。2011/12/28(水) 22:50:20.34ID:NwwVKbBP
EPSONの最近の機種ならOK

106名無しさん@お腹いっぱい。2011/12/28(水) 23:24:52.68ID:c57oosf9
大手ならエプソン、hpあたり。
ブラザーもありだと思う。
キヤノンはwindowsで使うにはよいが、linuxでは難しい。

107名無しさん@お腹いっぱい。2011/12/29(木) 10:54:51.91ID:kvpyOCw2
>>104
ブラザーのmfc870をCentOSとGentoo(Winもあるけど)で使ってるけど、問題ないよ。
文章も写真もそこそこの品質で印刷できてる。
以前はインクがブラザーだけ高くてネックだったけど、最近は大分こなれてきたしね。

108名無しさん@お腹いっぱい。2011/12/29(木) 16:08:12.35ID:UeupUCJS
>>105-107

EPSON、hp、brotherあたりなら無難なのか
メーカーが絞られただけでも選びやすくなった

ありがとう

109名無しさん@お腹いっぱい。2011/12/29(木) 16:37:22.64ID:00S4PqR+
たしかキヤノも、一覧に出てこなくてもてきとーな機種選んでおけば
印刷だけはできたと思うよ。
PDLなんてBJのころからたいして変わってないんだし。

110名無しさん@お腹いっぱい。2011/12/29(木) 23:28:54.90ID:uqbdJ4vp
>>109
でもね、綺麗にはならないんですよ。
今年も年賀状の出来が悪い。
ちなみに、CANONの950iをUbuntuで動かしています。
950iが一覧に無くて、というより、Canonから発売されたものがほとんど無いってのは
どういうこと?

111名無しさん@お腹いっぱい。2011/12/30(金) 11:12:44.10ID:6F96kmSf
>>110
これ使ってるのかな?
http://bit.ly/sO5fcS
ubuntuでもRPM使えたよね?

1121102012/01/03(火) 01:33:42.34ID:ALwPlLTG
>>111 それもダウンロードしたところまではいいんだけど、展開してくれません。

113名無しさん@お腹いっぱい。2012/01/03(火) 19:18:10.08ID:+YegtDiC
>>112

alien入れてdebパッケージに変換したほうが安全そうだね。

114名無しさん@お腹いっぱい。2012/01/18(水) 14:55:52.57ID:d87TADoh
CANON MF4010とiP4600使っていたよ。
iP4600はLinuxからだと色が綺麗に出せなかった。

115名無しさん@お腹いっぱい。2012/03/20(火) 18:45:58.80ID:yUaMdM6a
canonも新型の複合機は対応が良くなってるのな
MGシリーズ全機種64bitのLinuxドライバあってびびったわ
旧型機は完全に切り捨てられてるけど

116名無しさん@お腹いっぱい。2012/04/29(日) 22:27:10.61ID:F7ptDMUh
HPの安物オフィス複合機、Ubuntu/Fedora/Debianで完璧に動作中

117名無しさん@お腹いっぱい。2012/05/04(金) 16:53:04.55ID:sdL/IW4X
HPは基本的に動くんだよ。

118名無しさん@お腹いっぱい。2012/05/06(日) 12:38:46.85ID:rr1/Ajmm
Ubuntu Linux 12.04 LTS 64bit版でCanon MP640 (LAN接続)の設定を済ませました。
MP640のLinuxドライバは32bit用しかありませんが、下記ページに従いプリンタドライバの
インストールスクリプトを書き換えてインストールしたら印刷できるようになりました。

MP640/Canon on linux+CUPS
http://gem.mydns.jp/daitei/linux/printer/mp640.html

ScanGear MPの方は強引にインストールしても、
libgimp2.0が64bit版なのでダイナミックリンクに失敗して起動できませんでした。

xsaneをインストールしたらlibsaneもインストールされスキャンできるようになりました。
Ubuntu Linux 12.04はsane-backends-1.0.22を採用しているので、
下記ページでSupportedになっているスキャナなら使えるはずです。

SANE: Supported Devices
http://www.sane-project.org/sane-mfgs.html
>The following table summarizes the devices supported by sane-backends-1.0.22.

119名無しさん@お腹いっぱい。2013/06/26(水) 22:56:37.52ID:xPz7avpg
canonのMP980オフィシャルではドライバ公開してくれなかったが
いつの間にかgutenprintに入ってたわ。全然気づいてなかった俺アホだわ。
これで無線スキャナプリントがまともにできる

120名無しさん@お腹いっぱい。2013/11/29(金) 18:44:42.08ID:mCXy0aa/
Fedora19にキヤノンプリンタ用ドライバをインストールする際、
libtiff.so.3がなくてうまく行かない場合は、以下で対処可能。
参考まで。
http://phracek.fedorapeople.org/libtiff3/

今年買ったモデルのドライバがFedora16用とか勘弁してほしいわ。
キヤノンはHP,EPSON,Brotherに比べてLinux対応が全然だめだね。
Windows使っていた頃はキヤノン派だったけど、もう二度とキヤノン買わねえ。

121名無しさん@お腹いっぱい。2013/12/07(土) 20:35:25.23ID:OmjWo5Mg
windowsなら最近のやつならつないだらすぐ使えるのにな。

122名無しさん@お腹いっぱい。2013/12/08(日) 08:42:16.97ID:VDErZYOr
そうでもない。
エプソンの複合機のドライバ、Win8に
対応してるはずなのにインスコ途中で止まるぞ。

123名無しさん@お腹いっぱい。2014/01/18(土) 22:53:50.17ID:WpdURPQP
質問です。
EPSON EP-705Aを、EPSON配布のドライバで使っています。
OSは、ubuntu 13.10です。

pdfファイルを印刷する分には問題ないのですが
psファイルを印刷すると、ことごとく白黒で出ます。
そういうものでしょうか?

[NGパターン] 黒白で出ます。
lpr hogehoge.ps (psファイル自体は、英語版のacrobat readerに吐かせました。)

[OKパターン] カラーで出ます。
プリンタのプロパティから、テスト印刷。
chrominumからのWebページ印刷。
lpr hogehoge.pdf
ps2pdf hogehoge.ps | lpr

フィルタの設定だと思うのですが、それっぽいところが見つからず。。。
使っているドライバ verはこれです。

$ sudo dpkg -l |grep -i epson
ii epson-inkjet-printer-201205j 1.0.0-1lsb3.2 i386 EPSON EP-705A Series - Epson Inkjet Printer Driver

124名無しさん@お腹いっぱい。2016/09/03(土) 21:51:29.08ID:5kybXc/1
>>118
Ubuntu 14.04 (64bit)でCanonのネットワークプリンタを使う
http://qiita.com/ma2shita/items/481d8f6625469e1defe2
Ubuntu Linux 16.04 (64bit)はこの方法でLAN接続のCanon MP640を使えた。
公式ドライバは不要でcups-backend-bjnpをインストールするだけだ。

>>119
プリンタを設定する (Ubuntu 14.04, 13.10)
http://www.linuxmania.jp/use_printer_ubuntu.html
Gutenprint Supported Printers
http://gimp-print.sourceforge.net/p_Supported_Printers.php
pinter-driver-gutenprintが広く網羅しているから本当に簡単になったね。

>>120
プリンタを設定する (Fedora 7) (Fedora, Scientific Linux, CentOS)
http://www.linuxmania.jp/use_printer.html
CanonのLinux用公式ドライバは発売時点のディストリ用しか公開されない。
Fedora16が2011-11-08、Fedora17が2012-05-29、Fedora19が2013-07-02だから
Fedora16用が公開されている機種ならFedora19のGutenprintでサポート済みだろう。
ディストリでサポート済みなら公式ドライバにこだわる必要はないと思う。

125名無しさん@お腹いっぱい。2017/05/06(土) 22:04:59.22ID:XthGJmzv
Xerox の DocuPrint CP210dw / CP310dw が linux で使えてる人いますか?

仕様↓によれば、この二つは pdf プリントに対応しておらず、
http://www.fujixerox.co.jp/product/printer/docuprint_cp310dw/spec.html
したがって pdf プリントを使ってる linux ドライバでは動かないはずですが、ドライバ↓の対応一覧
http://www.fujixerox.co.jp/download/docuprint/download/p450d/linux/
に名前が載ってます。

1. pdf プリントでなくちゃんと PCL でラスタ展開するドライバが入っている。
2. 仕様表が間違いで pdf プリントに対応してる。
3. ドライバの対応一覧が間違ってる。

CP210 の複合機版である CM210 は pdf プリントに対応していて上記ドライバで動くのでその類推で手がすべったとか、
OEM先の NEC Color MultiWriter 5800C / 5850C が linux 対応してる雰囲気がない↓
http://jpn.nec.com/printer/laser/support/os/linux/index.html
ところからみて、3 だと思ってるんですが、どうでしょうか?

126名無しさん@お腹いっぱい。2017/12/28(木) 11:40:12.99ID:22Y5RTGK
誰でも簡単にネットで稼げる方法など
参考までに、
⇒ 『加藤のセセエイウノノ』 というサイトで見ることができるらしいです。

グーグル検索⇒『加藤のセセエイウノノ』

UZ5CYX25YB

新着レスの表示
レスを投稿する